Delivery Report delays towards Telia Norway

Incident Report for GatewayAPI

Resolved

Delivery reports towards Telia Norway is now back to normal.

We will keep monitoring for good measure.

We are sorry for any inconveniences this may have caused.
Posted Jun 19, 2026 - 18:48 CEST

Monitoring

We are currently monitoring the Delivery Report issue reported by Telia Norway.

Users may experience a delay receiving delivery reports on messages sent to Telia Norway recipients.

Messages are delivered, it is only the status reports that are delayed.
Posted Jun 19, 2026 - 17:22 CEST
This incident affected: Specific country (Norway), Message Services - Commercial (Delivery Reports (DLR) - Commercial), and External Provider.