Phishing attack
Incident Report for GatewayAPI
Resolved
Everything is running smooth again.
Between 22:47 and 00:03 CEST, all traffic was suspended on GatewayAPI.com. Messages received during this time frame was simply queued, while we dealt with the attacker. It took a little more than an hour because we had to work in a few code changes to prevent further attacks.
We are very sorry.
Posted about 2 years ago. Oct 09, 2016 - 00:53 CEST
Monitoring
All new accounts are now created as read only, with manual identity verification needed to prevent further attacks. Prior to these attacks we where already working on adding additional automated identity verification, so this will be the main focus of our next sprint.
Also I'm please to say that the queues have been cleaned for phishing sms'es and operation has resumed, all messages received during the cleaning process was queued and delivered.
The unfortunate recipients of the SMS'es have been notified. We are monitoring our systems on weekends as well, and caught the attack early on.
Posted about 2 years ago. Oct 09, 2016 - 00:16 CEST
Identified
Messages are temporary suspended due to an ongoing phishing attack using GatewayAPI.com to send phishing SMS'es. We are in the process of clearing phishing SMS'es from the queue.
Until we can add additional account verification, all new accounts must be manually verified before given access to GatewayAPI.com. We are sorry for this inconvenience.
Posted about 2 years ago. Oct 08, 2016 - 22:59 CEST