Messages are delivered up to three times
Incident Report for GatewayAPI
Resolved
After a quick examination, the components affected was restarted and the connection is reestablished. If we don't get an successful callback from the SMSC connection, our current policy is to re-attempt delivery up to three times, with 180 seconds between each. These re-attempts are not charged to your account.
We are very sorry for the inconvenience and will look into this situation in further detail, possibly with a post-mortem writeup with our findings. At first glance the situation coincides with the failure of a non-critical system which built up a large backlog. These might be related but we will need further analysis to find out. However with all systems fully operational, and a stable connection there will not be any further re-attempts, leading us to resolve the matter at this time.
Posted over 2 years ago. May 01, 2016 - 17:21 CEST
Identified
Some messages did not get a positive acknowledgement that they where sent, and delivery was subsequently re-attempted up to three times as is our policy to ensure delivery even in erroneous situations. We have identified the fault and are working to resolve the matter.
Posted over 2 years ago. May 01, 2016 - 16:48 CEST